Are You Ready for WordPress 3.2?

WordPress 3.2 was released yesterday and the minimum technical requirements have changed for your website back-end (PHP and MySQL) and your web browser (no more old, out-of-date browsers like Internet Explorer 6).

PHP and MySQL

As of WordPress 3.2, you’ll need to be running PHP 5.2.4 and MySQL 5.0. The percentage of people running older versions of PHP and MySQL is relatively low. Most of the major hosts already default to these or newer versions, but there are some exceptions.

To find out if you have the latest version of PHP and MySQL:

  • Contol Panel – Log into your hosting account panel and check to see which versions you are running, if you’re still on an older version, it should be as simple as changing a dropdown menu and clicking Save to get up to date
  • Plugin – You can find out if you’re ready for WordPress 3.2 with the Health Check plugin. In your dashboard, go to Plugins → Add New and search for “health check” (it should be the first result). Install it, activate it, and it will tell you if you need to update anything.
  • Tech Support – Contact your host’s customer service and ask them to confirm which version of PHP and MySQL you are running and to ask them to or walk you through how to upgrade your account. If your host can’t update to these versions, it might be time to look for a new host.
  • Contact Us – We’re happy to check to see if your hosting is up to the task of upgrading to WordPress 3.2 and we’ll even backup and upgrade your site for you.

Internet Explorer 6 and Outdated Browsers

WordPress 3.2 is dropping support for Internet Explorer 6, a 10-years-old outdated browser that even Microsoft is ready to leave behind. Why? Because as web technology improves, so does WordPress and to take advantage of these improvements old, out-of-date browsers need to be left behind.

If your browser is out of date, you’ll see a friendly orangey-yellow box in your dashboard letting you know you a newer version is available (which you can dismiss, of course). If you’re using IE6, though, the box will be red, and your dashboard will not function properly. If you’re stuck on IE6 because the computer you use is maintained by a business, library, school, or the like, and you are not able to download a newer browser, here’s a sample email you can use to ask your boss/administrator/IT guys to update the browser.

Hi there. The computer I use at [where you use the computer] is equipped with an out-of-date web browser. Internet Explorer 6 was created 10 years ago, before modern web standards, and does not support modern web applications. More and more sites and applications are dropping support for IE6, including the new version of WordPress. Even Microsoft, the makers of IE6, are counting down until IE6 goes the way of the dinosaur (see http://www.ie6countdown.com/ for more information). Can you please install an updated version of IE or any modern browser (see http://browsehappy.com for more information) on the available computers? Thank you very much.